趋势划线主图指标 源码 趋势和黄金分割两套选股 贴图(图文)

时间:2019-08-20 18:28:51 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

趋势划线主图指标 源码 趋势和黄金分割两套选股 贴图

指标构思
这套指标是先找出最近N周期(可自行修改周期)从左往右的远高点,再找到今天向右N周期的近高点。将两点连线后,对突破黄色趋势线和枚红色黄金分割618位置进行选股。
远高点和近高点水平画线不能进行选股,因为如果突破这两条线那么画线将重新画。
黄金618位置是近高点和近高点形成后产生的最低点进行分割。
附件分为主图信号画线和二套选股(趋势选股 黄金分割选股)
指标只是参考,选股和参数还需要各自琢磨!!






{主图信号}

N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH);
LL:=CONST(REF(L,JD));
黄金线:IF(CURRBARSCOUNT<=CONST(JH)+1,(CONST(DH)-CONST(LL))*0.618+CONST(LL),DRAWNULL),DOTLINE,COLORMAGENTA;
IF(CURRBARSCOUNT<=CONST(JH)+1,CONST(DH),DRAWNULL),DOTLINE,COLORLIRED;
IF(CURRBARSCOUNT<=CONST(YH)+1,CONST(HH),DRAWNULL),DOTLINE,COLORYELLOW;
EXT1:DRAWLINE(QD,H,ZD,H,1),DOTLINE,COLORYELLOW;
STICKLINE(QD,H,L,0,0),COLORYELLOW;
STICKLINE(QD,C,O,2,0),COLORYELLOW;
STICKLINE(ZD,H,L,0,0),COLORLIRED;
STICKLINE(ZD,C,O,2,0),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=CONST(YH)+10,CONST(HH),VARCAT(VARCAT('远高价',VAR2STR(CONST(HH),2)),'元')),COLORYELLOW;
DRAWTEXT(ZD,H*1.02,VARCAT(VARCAT('近高价',VAR2STR(H,2)),'元')),COLORLIRED;
DRAWICON(CROSS(C,EXT1) AND CURRBARSCOUNT<CONST(JH)+1,L,1);
DRAWICON(CROSS(C,黄金线) AND CURRBARSCOUNT<CONST(JD)+1,L,25);


{突破黄金线选股}
N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH) ;
LL:=CONST(REF(L,JD));
黄金线:=IF(CURRBARSCOUNT<=CONST(JH)+1,(CONST(DH)-CONST(LL))*0.618+CONST(LL),DRAWNULL);
CROSS(C,黄金线) AND CURRBARSCOUNT<CONST(JD)+1;

{突破黄色趋势线选股}
N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH) ;
LL:=CONST(REF(L,JD));
EXT1:=DRAWLINE(QD,H,ZD,H,1);
CROSS(C,EXT1) AND CURRBARSCOUNT<=CONST(JH)+1;


后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)