CCI指标优化版(通达信公式 副图 源码 测试图)(图文)

时间:2019-10-20 18:36:13 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

用法自己琢磨了不多说了  CCI过线上牛和MACD金叉共振 买入   选股买红线黄线两线之间的股票。一旦CCi 上 100就进入强势区。手机上无法显示买进卖出 自己看!

TYP:=IF((H>C AND C>O) OR (H>O AND O>=C),C,H)+IF((L<C AND C<O) OR(L<O AND O<=C),CLOSE,LOW)/3;
CCI:EMA((TYP-MA(TYP,36.0270012))/(0.015*AVEDEV(TYP,36.0270012)),2.0332),colorgreen;
STICKLINE(CCI>100,CCI,100,8,0),colormagenta;
STICKLINE(CCI<-150,CCI,-150,8,0),coloryellow;
STICKLINE(C>0,100,101,10,0),colorred;
STICKLINE(C>0,-150,-151,6,0),colorgreen;

RSV:= (C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
FASTK:=SMA(RSV,3,1);
Y1A:=((SMA(FASTK,3,1))/2+40)*1.1;
线上牛:SMA(Y1A,3,1),coloryellow;
RSV1:= (HHV(H,9)-C)/(HHV(H,9)-LLV(L,9))*100;
Y2A:=(SMA(RSV1,3,1)/2)*1.1;

LC := REF(C,1);
RSI2:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100;
RSI3:=IF(RSI2>50,RSI2*1.05,RSI2);
RSV3:=(C-LLV(L,54))/(HHV(H,54)-LLV(L,54))*100;
RSI4:=IF(RSI3>100,100,RSI3);
RRR:= EMA(SLOPE(RSI4,3),20);


DRAWICON(CROSS(CCI,线上牛),线上牛,1);
DRAWICON(CROSS(线上牛,CCI),线上牛,2);


突破


AN:=10;
AA:=REF(H,AN)=HHV(H,2*AN+1);
QY:=BACKSET(AA,AN+1);
ACC:=FILTER(QY,AN) AND H=HHV(H,AN+1);
AAA1:=CROSS(BACKSET(BARSTATUS=2,SUMBARS(ACC,1)),0.5);
AB1:=CROSS(BACKSET(BARSTATUS=2,SUMBARS(ACC,2)),0.5);
HQSXG:=DRAWLINE(AB1,H,AAA1,H,1);
上突破:=CROSS(C,HQSXG) AND HQSXG>REF(HQSXG,1);
下突破:=CROSS(C,HQSXG) AND HQSXG<REF(HQSXG,1);
XG:上突破 OR 下突破;
 

CCI指标优化版 通达信

CCI指标优化版 通达信

CCI指标优化版 通达信


后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)