两点买入,主图画线公式,全网唯一和谐预测赢家(通达信公式 主图 源码 测试图)分享源码(图文)

时间:2020-04-05 20:11:01 作者:admin

两点买入,主图画线公式,全网唯一和谐预测赢家(通达信公式 主图 源码 测试图)分享源码

 

公式不错,公布源码如下


{公式名称: 两点买入

 

参数数量: 2

参数1: 最高1, 最小: 1, 最大: 1000, 缺省: 5, 日线: 10

参数2: 最低1, 最小: 1, 最大: 1000, 缺省: 5, 日线: 39

公式类型: 技术指标公式-其他类型

画线方法: 主图叠加

}

 

最高价格:HHV(REF(HIGH,最高1-1),2),NODRAW;

最低价格:LLV(REF(LOW,最低1-1),2),NODRAW;

VAR1:=最高价格/最低价格;

VAR2:=SQRT(VAR1);

VAR3:=SQRT(VAR2);

VAR4:=最高价格/VAR3;

预测上点:CONST(VAR4),NODRAW;

VAR5:=最高价格/最低价格;

VAR6:=SQRT(VAR5);

VAR7:=最高价格/VAR6;

预测中点:CONST(VAR7),NODRAW;

VAR8:=最高价格/最低价格;

VAR9:=SQRT(VAR8);

VAR10:=SQRT(VAR9);

VAR11:=VAR9+VAR10-1;

VAR12:=最高价格/VAR11;

预测下点:CONST(VAR12),NODRAW;

STICKLINE(CURRBARSCOUNT<=最高1,预测下点,预测下点,5,0),COLORWHITE,LINETHICK2;

STICKLINE(CURRBARSCOUNT<=最高1,预测上点,预测上点,5,0),COLORWHITE,LINETHICK2;

STICKLINE(CURRBARSCOUNT<=最高1,预测中点,预测中点,5,0),COLORWHITE,LINETHICK2;

VAR13:=REFDATE(HHV(HIGH,最高1),DATE);
WWW70822COM:=REFDATE(HHV(HIGH,最高1),DATE);

VAR14:=REFDATE(LLV(LOW,最高1),DATE);

STICKLINE(CURRBARSCOUNT=最高1,VAR13,VAR14,0,(-1)),COLORYELLOW;

VAR15:=REFDATE(HHV(HIGH,最低1),DATE);

VAR16:=REFDATE(LLV(LOW,最低1),DATE);

STICKLINE(CURRBARSCOUNT=最低1,VAR15,VAR16,0,(-1)),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=最高1,VAR14,77),COLORWHITE;

DRAWTEXT(CURRBARSCOUNT=最低1,VAR14,78),COLORWHITE;

 

 


声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。